Aide d'Ant Movie Catalog

Ant Movie Catalog

Version 3.5

Utilisez l'index dans la fenêtre de gauche pour parcourir ce fichier d'aide


Ant Movie Catalog Help

Informations générales

Ce programme permet de gérer des catalogues de films. Cela signifie que vous pouvez avoir plusieurs catalogues pour classer des films séparément. Chaque catalogue peut contenir un nombre quasi infini de films, et est stocké dans un fichier ayant une extension ".amc" ou ".xml" selon le format choisi. Ces catalogues peuvent être gérés via les icônes [image] Nouveau, [image] Ouvrir, [image] Sauver and [image] Sauver sous de la barre d'outils et du menu Fichier.

Lorsqu'un catalogue est ouvert (ou qu'il est vide), vous pouvez ajouter de nouveaux films via l'icône [image] Ajouter qui affichera la fenêtre de sélection de numéro (chaque film doit avoir un numéro, mais vous pouvez cocher la case "Ne plus afficher" afin d'utiliser la numérotation automatique). À l'aide de cette commande, vous pouvez ajouter vos films au catalogue, n'oubliez pas de le sauver de temps en temps.

Vous pouvez maintenant remplir les différents champs. L'icône [image] Extraction d'information affiche un menu permettant d'importer des informations de fichiers ou d'un script.

  • L'importation de fichiers tentera de prendre toutes les informations utiles dans les fichiers multimédia (.avi, .mpeg, etc.). Vous pouvez aussi effectuer un glisser-déposer (drag & drop) des fichiers depuis l'Explorateur Windows vers la fenêtre de Ant Movie Catalog.
  • L'importation d'un script affiche la fenêtre Scripting proposant des scripts pour l'importation d'informations depuis divers sites web. Il s'agit de la manière la plus simple de remplir les différents champs relatifs aux films si vous disposez d'une connexion à Internet.

Vous pouvez aussi stocker ou lier une image au catalogue. Certains scripts fournissent une image lors de l'importation des informations, mais vous pouvez également manuellement ajouter une image stockée dans votre orginateur en cliquant sur l'icône [image] Sélectionner une image (située en bas à gauche de la fenêtre principale) ou via un glisser-déposer de l'image depuis l'Explorateur Windows.

Si votre liste actuelle est dans un autre format (par exemple un document Microsoft Excel) vous pouvez utiliser la fenêtre d'Importation pour la transférer dans le catalogue courant.

N'hésitez pas à découvrir toutes les fonctionnalités offertes dans les menus. Prenez aussi le temps d'inspecter toutes les réglages disponibles dans la fenêtre des Options via l'icône [image] Options.


Informations d'un film

Dans la fenêtre principale vous pouvez entrer pas mal d'informations pour chacun des films :

  • Label du support : Vous pouvez indiquer ici le numéro du disque, de la cassette, le code-barre, un label, ou n'importe quoi d'autre
  • Type de support : Le support utilisé pour stocker le film (CD, DVD, VHS, etc...)
  • Origine : Où/Comment vous avez eu ce film
  • Date d'ajout : Date à laquelle le film a été ajouté à la liste
  • Emprunté par : Nom de la personne qui a emprunté le film
  • Note : Avez-vous aimé le film ? Vous pouvez le dire ici
  • Titre original
  • Titre traduit
  • Réalisateur
  • Producteur
  • Pays
  • Catégorie
  • Année
  • Durée : Longueur du film, en minutes
  • Acteurs
  • Adresse web : Vous pouvez indiquer ici une adresse de site web en relation avec le film. Vous pouvez lancer le navigateur par défaut pour ouvrir cette URL en cliquant sur le bouton à droite du champ
  • Description
  • Commentaires
  • Format vidéo : Codec ou média utilisé pour la vidéo
  • Débit vidéo : Débit de la vidéo en kilobits par seconde
  • Format audio : Codec ou média utilisé pour l'audio
  • Débit audio : Débit de l'audio en kilobits par seconde
  • Résolution : Largeur et hauteur du film (ex. 640x480)
  • Fréquence : Nombre d'images par seconde
  • Taile des fichiers : Taille en méga-octets du film. Il peut y avoir plusieurs fichiers (ex. 650+590 ou 1240)
  • Nombre de disques : Nombre de disques ou de cassettes
  • Langues
  • Sous-titres

Toutes les listes déroulantes stockent et récupèrent leurs valeurs du fichier XML où sont stockées les préférences. Vous pouvez les modifier dans la fenêtre des Options dans la rubrique "Listes déroulantes". Une option permet d'utiliser les valeurs du catalogue courant plutôt que les listes prédéfinies.

Il y a deux "champs" additionnels qui apparaissent dans certaines fenêtres :

  • Coché : L'état des cases à cocher dans la liste principale ; elles peuvent être activées via les Options si vous ne les voyez pas
  • Titre formaté : Titre utilisé dans la liste principale, qui peut combiner à la fois le titre original et le titre traduit par exemple ; consultez la page des Options pour plus d'informations


Ant Movie Catalog Help

Impression

Dans cette fenêtre vous pouvez prévisualiser les rapports avant leur impression.

Sélectionnez un modèle dans la liste de gauche pour le prévisualiser. Cette liste propose tous les fichiers trouvés dans le sous-dossier "Templates".

Si vous voulez ouvrir un modèle présent dans un autre dossier, vous pouvez utiliser le bouton "Charger un modèle".

Vous pouvez spécifier un ordre de tri : par numéro, par titre original, par titre traduit, ou choisir les options de tri avancées. Lorsque vous sélectionnez cette option, une fenêtre apparaît et vous permet de choisir quel champ doit être inclus dans le tri, et dans quel ordre.

Les options "Films à inclure" permettent de restreindre l'impression aux films sélectionnés, cochés (lié à l'option "Cases à cocher") ou visibles (lors de l'utilisation de l'option "Afficher les résultats" de la fonction de recherche de la fenêtre principale).

Lorsque vous êtes prêts à imprimer, cliquez sur le bouton "Imprimer". Une fenêtre de confirmation s'affiche alors, permettant de sélectionner l'imprimante à utiliser.

Note importante : Si vous voulez utiliser une autre taille de papier, vous devez modifier le modèle avec le Designer (par défaut la taille de papier est généralement A4, mais en fait ça dépend de qui a fait le modèle).

Si vous désirer modifier un modèle ou en crée vous-même, cliquez sur le bouton "Report Designer". Pour obtenir de l'aide sur son utilisation, consultez la page Création de rapports dans la section consacrée aux Informations techniques.


Importation depuis un autre format

Vous pouvez importer des données dans la liste de films depuis un autre format de fichier.

Sélectionnez un format dans la liste de la partie gauche de la fenêtre d'importation, et ensuite sélectionnez le fichier source.

Formats disponibles :

  • CSV (peut être utilisé pour importer de Microsoft Excel ou d'autres programmes)
  • AMC (Ant Movie Catalog)
  • BaseDVDivx
  • Divx Manager / eXtreme Movie Manager
  • Origons.com

L'option "Permettre les doublons dans les n°" peut être utilisée si vous voulez être sûr que les films importés conservent leur numéro. Lors de l'importation d'un film, si cette option n'est pas activée et qu'il y a déjà un film avec le même numéro, le nouveau film importé recevra un nouveau numéro.


Importation CSV

CSV est un format de fichier texte qui est très utile du fait que beaucoup de programme permettent d'ouvrir et enregistrer ce type de fichiers (par exemple Microsoft Excel).

Dans ces fichiers chacun des enregistrements est sur une ligne et les champs sont séparés par un caractère (généralement une virgule ou un point-virgule).

Quand vous importez ce type de fichiers, chaque ligne sera considérée comme un film dans la liste. Ensuite la ligne est séparée en plusieurs champs. Le programme ne peut pas devinner à quel champ du film corresond chacune des colonnes des enregistrements CSV. Vous allez donc devoir le lui expliquer.

Pour cela vous devez sélectionner le nom du champ dans la liste déroulante "Champs disponibles", et ensuite cliquer sur le titre (en-tête) de colonne correspondant à la valeur sélectionnée, comme montré sur les captures d'écran ci-dessous :

Répétez cette étape pour chacune des colonnes qui doit être importée.

Si vous n'associez pas de nom de champ à une colonne, cette colonne ne sera pas utilisée pour l'importation de données.

Si aucune colonne "Numéro" n'est spécifiée, les numéros seront créés à patir du plus haut numéro existant + 1. Idem pour les numéros provenant du fichier CSV et étant déjà présents dans la liste, donc il n'y a pas de numéros en double.


Importation Ant Movie Catalog

Ceci vous permet d'importer des films d'un autre catalogue. Vous pouvez importer de n'importe quelle version de Ant Movie Catalog, sauf les versions plus récentes que la version actuelle bien sûr.

Notez que lors de la mise à jour vers une nouvelle version de Ant Movie Catalog, vous n'avez pas besoin d'importer votre catalogue dans un nouveau catalogue, vous pouvez directement ouvrir l'ancien catalogue, le programme le convertira lors de la première sauvegarde.


Importation BaseDVDivx

BaseDVDivx est un ancien programme français de gestion de films, qui utilise des bases de données MyLittleBase, avec ".bdv" comme extension.

L'importation a été testée avec succès avec le fichier d'exemple accompagnant la version 2.5 de BaseDVDivx.

S'il y a des images dans le catalogue, le programme va demander ce que vous voulez en faire. Vous avez alors quatre choix :

  • Stocker : Stocke les images dans le catalogue. Cela rend le fichier assez énorme si les images sont grandes. Si vous sauvez en XML, les images seront ré-exportées lors de la sauvegarde car elles ne peuvent pas être stockées dans le fichier XML.
  • Copier & Lier : Copie les images dans le dossier du catalogue courant, et crée un lien vers elles. Les images d'origine ne sont donc plus nécessaires. Ceci n'est pas disponible si le fichier courant n'a pas encore été sauvé quelque part.
  • Lier : Crée un lien vers les images, vers leur emplacement d'origine. Vous devez donc conserver les images là où elles sont.
  • Pas d'images : Vide le champ d'image.

Il y a un cinquième choix caché : si vous annulez cette fenêtre (avec le X dans le coin, ou avec la touche Esc), le champ d'image sera pas modifié, et il contiendra le nom de fichier de l'image tel qu'il était dans le fichier importé. Donc vous pouvez copier manuellement les images vers le dossier du catalogue.


Importation Divx Manager / eXtreme Movie Manager

Divx Manager / eXtreme Movie Manager est un programme pour la gestion de films, qui utilise des bases de données Microsoft Access, avec ".mdb" comme extension.

Site web : www.binaryworks.it/extrememoviemanager

L'importation a été testée avec succès avec les fichiers d'exemple accompagnant les versions 0.5, 0.6, 0.8, 0.9 et 1.0 de Divx Manager.

S'il y a des images dans le catalogue, le programme va demander ce que vous voulez en faire. Vous avez alors quatre choix :

  • Stocker : Stocke les images dans le catalogue. Cela rend le fichier assez énorme si les images sont grandes. Si vous sauvez en XML, les images seront ré-exportées lors de la sauvegarde car elles ne peuvent pas être stockées dans le fichier XML.
  • Copier & Lier : Copie les images dans le dossier du catalogue courant, et crée un lien vers elles. Les images d'origine ne sont donc plus nécessaires. Ceci n'est pas disponible si le fichier courant n'a pas encore été sauvé quelque part.
  • Lier : Crée un lien vers les images, vers leur emplacement d'origine. Vous devez donc conserver les images là où elles sont.
  • Pas d'images : Vide le champ d'image.

Il y a un cinquième choix caché : si vous annulez cette fenêtre (avec le X dans le coin, ou avec la touche Esc), le champ d'image sera pas modifié, et il contiendra le nom de fichier de l'image tel qu'il était dans le fichier importé. Donc vous pouvez copier manuellement les images vers le dossier du catalogue.


Importation Origons.com

Site web : www.origons.com

Ceci permet d'importer un fichier contenant votre liste de films dans un format standardisé, qui est généré par le site web Origons.com. Ce site permet de gérer sa liste de films en ligne.


Exportation vers un autre format

Vous pouvez exporter la liste de films vers d'autres formats courrants, par exemple pour la publication, l'impression ou l'échange avec d'autres personnes.

Formats disponibles :

  • HTML
  • CSV (peut être importé dans Microsoft Excel et pas mal d'autres programmes)
  • SQL
  • Images uniquement ("Images only")
  • Origons.com

Vous pouvez spécifier un ordre de tri : par numéro, par titre original, par titre traduit, ou choisir les options de tri avancées. Lorsque vous sélectionnez cette option, une fenêtre apparaît et vous permet de choisir quel champ doit être inclus dans le tri, et dans quel ordre.

Les options "Films à inclure" permettent de restreindre l'exportation aux films sélectionnés, cochés (lié à l'option "Cases à cocher") ou visibles (lors de l'utilisation de l'option "Afficher les résultats" de la fonction de recherche de la fenêtre principale).

L'option "Copier les images vers le même répertoire que le fichier exporté" permet de spécifier si vous voulez exporter les images en plus des informations des films.


Exportation vers HTML

L'option "Exporter en HTML" vous permet de créer un fichier HTML contenant votre catalogue complet dans un format portable. Vous pouvez publier cette liste sur le web ou la donner à n'importe quelle personne possédant un navigateur web.

Le fichier HTML généré est basé sur un fichier HTML réel. Le programm remplace certains tags spéciaux avec les informations des films et du catalogue.

Il y a deux modèles différents : "Complet" et "Individuel". Les anciennes versions du programme n'avaient que le modèle "Complet". Ce modèle Complet correspond à un seul fichier, avec la liste de tous les films. Son nom est le nom que vous sélectionnez lorsque vous cliquez sur le bouton "Exporter". Le modèle Individuel correspond à un fichier par film, avec les informations de chaque film. Par défaut le nom est la concaténation du nom que vous sélectionnez lorsque vous cliquez sur le bouton "Exporter" et le numéro du film (vous pouvez changer ça dans la fenêtre des Préférences).

Donc si vous exportez le catalogue vers "Mes films.html" vous aurez :

  • Mes films.html -> La liste des films, page basée sur le modèle chargé dans l'onglet "Complet"
  • Mes films_1.html -> Le premier film, page basée sur le modèle chargé dans l'onglet "Individuel"
  • Mes films_2.html -> Le second film, page basée sur le modèle chargé dans l'onglet "Individuel"
  • etc...

À droite de la sélection du modèle (boutons "Complet"/"Individuel") vous pouvez sélectionner si vous voulez exporter les deux modèles ou juste celui qui est sélectionné.

Tous les tags commencent par "$$". Vous n'avez pas nécessairement besoin de les connaître étant donné qu'ils sont accessibles via le menu "Insérer un tag spécial". Ils couvrent toutes les informations que vous pouvez entrer pour un film, mais aussi le nombre total de films, le nom du catalogue, la date et l'heure.

Il y a deux tags très importants pour le modèle "Complet": $$ITEM_BEGIN et $$ITEM_END. Lors de la création du fichier HTML, le programme va répéter le morceau de code HTML placé entre ces deux tags spéciaux pour chaque film. Donc tous les tags commençant par $$ITEM_ doivent être placés entre ces deux tags. Par contre pour le modèle "Individuel" ces tags sont inutiles.

L'application inclut un modèle d'exemple que vous pouvez utiliser et personnaliser. Bien sûr vous pouvez en créér un à partir de zéro si vous préférez, mais je recommande que vous observiez alors ce modèle de base :

<html>
  <head><title>$$FILENAME</title></head>
  <body><table>
    $$ITEM_BEGIN
      <tr>
        <td>$$ITEM_NUMBER</td>
        <td>$$ITEM_ORIGINALTITLE</td>
        <td>$$ITEM_TRANSLATEDTITLE</td>
        <td>$$ITEM_DESCRIPTION</td>
      </tr>
    $$ITEM_END
  </table></body>
</html>

Ici nous pouvons voir que la page aura comme titre le nom du fichier, et ensuite une table listant tous les films. Le programme va écrire le tag <table>, et ensuite répéter la séquence <tr>...</tr> pour chaque film car cette séquence est placée entre $$ITEM_BEGIN and $$ITEM_END.

Voici une liste des tags disponibles :

  • $$DATE = Date courante
  • $$TIME = Heure courante

Propriétés du fichier de catalogue :

  • $$FILENAME = Nom de fichier
  • $$FILEPATH = Nom de fichier avec chemin complet
  • $$TOTALMOVIES = Nombre de films dans le catalogue
  • $$OWNER_NAME = Nom spécifié dans les propriétés du catalogue
  • $$OWNER_MAIL = E-mail
  • $$OWNER_SITE = Site web
  • $$DESCRIPTION = Description
  • $$ITEM_FILEINDIV = Nom de fichier de la page du film courant, créée avec le modèle "Individuel"
  • $$ITEM_BEGIN = Début de liste de films
  • $$ITEM_END = Fin de liste de films

Champs de films :

  • $$ITEM_NUMBER = Numéro
  • $$ITEM_CHECKED = État de la case à cocher
  • $$ITEM_MEDIA = Label/code-barre du média
  • $$ITEM_TYPE = Type de support/média
  • $$ITEM_SOURCE = Source (origine)
  • $$ITEM_DATEADD = Date d'ajout
  • $$ITEM_BORROWER = Emorunteur
  • $$ITEM_RATING = Node (0 à 10)
  • $$ITEM_APPRECIATION = Appréciation, de 0 à 4 étoiles, utilisant appr*.gif
  • $$ITEM_ORIGINALTITLE = Titre original
  • $$ITEM_TRANSLATEDTITLE = Titre traduit
  • $$ITEM_FORMATTEDTITLE = Titre formaté, comme défini dans les Options
  • $$ITEM_DIRECTOR = Réalisateur
  • $$ITEM_PRODUCER = Producteur
  • $$ITEM_COUNTRY = Pays
  • $$ITEM_CATEGORY = Catégorie
  • $$ITEM_YEAR = Année
  • $$ITEM_LENGTH = Durée en minutes
  • $$ITEM_ACTORS = Liste des acteurs
  • $$ITEM_URL = Adresse web (sans lien)
  • $$ITEM_DESCRIPTION = Description
  • $$ITEM_COMMENTS = Commentaires
  • $$ITEM_VIDEOFORMAT = Format/codec vidéo
  • $$ITEM_VIDEOBITRATE = Débit vidéo
  • $$ITEM_AUDIOFORMAT = Format/codec audio
  • $$ITEM_AUDIOBITRATE = Débit audio
  • $$ITEM_RESOLUTION = Résolution vidéo
  • $$ITEM_FRAMERATE = Fréquence d'image de la vidéo
  • $$ITEM_LANGUAGES = Langues
  • $$ITEM_SUBTITLES = Sous-titres
  • $$ITEM_SIZE = Tailles des fichiers
  • $$ITEM_DISKS = Nombre de disques ou de cassettes
  • $$ITEM_PICTURE = Image, intégrée dans un tag <img>
  • $$ITEM_PICTUREFILENAME = Nom de fichier de l'image


Exportation vers CSV

CSV est un format de fichier texte qui est très utile du fait que beaucoup de programme permettent d'ouvrir et sauver ces fichiers (par exemple, Microsoft Excel).

Dans ces fichiers, chaque enregistrement (film) est sur une ligne, et les champs sont séparés par un caractère (habituellement une virgule ou un point-virgule).

Si vous activez l'exportation des images, une colonne "Picture" sera ajoutée, contenant le nom de fichier de l'image.


Exportation vers SQL

Il ne s'agit pas réellement d'un format de fichier, mais cette fonction vous permettra de générer toutes les commandes SQL nécessaires pour importer facilement la liste dans une base de données.

L'idée de départ était de créer une base de données mySQL, consultable à l'aide d'une page écrite en PHP, ce qui serait beaucoup plus interactif qu'une page HTML pour les gens consultant votre list si vous la placez sur le web.

Si vous activez l'exportation des images, une champ "PICTURENAME" sera ajouté, contenant le nom de fichier de l'image.

Il y a une option pour générer des requêtes UPDATE à la place des requêtes INSERT, si vous voulez mettre à jour les informations sans supprimer au préalable les données existantes. Cela provoque la mise à jour des films sur base de leur numéro, donc cela peut causer des problèmes pour certains films. Pour la même raison, le champ "Numéro" sera retiré de la liste des champs sélectionnés lorsque l'exportation se fait dans ce mode.


Exportation des images uniquement

Ceci vous permet d'extraire les images du catalogue.

Vous pouvez spécifier quels noms auront les images :

  • Rajouter le numéro de film au nom choisi : Lorsque vous cliquez "Exporter" vous devez sélectionner un nom de fichier. Ce nom de fichier sera utilisé comme base pour les noms des images ; le programme ajoutera le numéro de film à la fin du nom.
  • Utiliser le numéro de film.
  • Utiliser le titre (format défini dans les options de la liste de films) : Utilise le même format que pour la liste de films de la fenêtre principale.


Exportation vers Origons.com

Ceci va générer un fichier d'un format standardisé, qui permettra d'importer la liste de films sur le site Origons.com. Ce site permet de gérer sa liste de films en ligne : www.origons.com.


Films prêtés

Ce module vous permet de gérer les films que vous amis vous empruntent.

La liste dans la moitié supérieur de la fenêtre contient tous les films du catalogue courrant. Dans le coin inférieur gauche vous trouvez la liste des noms des emprunteurs. Dans le coin inférieur droit vous trouvez la liste des films qui sont actuellement empruntés par la personne sélectionnée (dans la liste à gauche).

Pour marquer un film comme "Emprunté", vous devez sélectionner le film, ainsi qu'un nom dans la liste des emprunteurs. Ensuite vous pouvez utiliser le bouton "Sortir", ou double-cliquer sur le film.

Pour retirer le status "Emprunté" d'un film, sélectionnez-le dans la liste de l'emprunteur, et cliquez sur le bouton "Rentrer" ou double-cliquez sur le titre du film.

Vous pouvez sélectionner plusieurs films à la fois à l'aide des touches Ctrl et Shift.

Si vous utilisez un numéro unique ou le champ "Label" pour indiquer que plusieurs films se trouvent sur le même support, vous pourrez avoir besoin des options "Inclure les films ayant le même numéro" et "Inclure les films ayant le même label" accessibles via l'icône "Options". Lorsque ces options sont activées, les films ayant le même numéro ou label que les films sélectionnés sont prêtés à la même personne (à moins qu'ils soient déjà assignés à quelqu'un d'autre).

Toutes les actions (entrées / sorties) sont enregistrées dans un fichier texte délimité par des tabulations. Consultez la page consacrée aux Options pour plus d'informations.


Scripting

Avec ce module vous pouvez récupérer des informations de films sur internet et les importer dans votre catalogue, ou appliquer un script à une liste de films.

Lorsque la fenêtre est appelée via le menu "Extraire des informations" -> "D'Internet via un script", les seuls scripts affichés sont ceux prévus pour la version 3.5 (au moins) et décrits comme permettant de récupérer des informations d'internet. Par défaut le script est appliqué aux films sélectionnés. Lorsqu'elle est appelée via le menu "Scripting", tous les scripts sont affichés.

Vous pouvez choisir de n'afficher que certains scripts. Ce choix s'effectue sur base de la langue définie dans les propriétés des scripts. Il s'agit de la langue dans laquelle sont les informations récupérées par le script. Cela s'applique donc plutôt aux script allant chercher des informations sur Internet. Ce filtrage s'effectue via le menu "Filtre de langue".

Pour démarrer un script, cliquez sur le bouton "Exécuter", ou double-cliquez sur son nom dans la liste affichée, ou bien appuyez Enter ou F9.

Les options "Films à inclure" permettent de restreindre le script aux films sélectionnés, cochés (lié à l'option "Cases à cocher") ou visibles (lors de l'utilisation de l'option "Afficher les résultats" de la fonction de recherche de la fenêtre principale).

Le script est exécuté pour chaque film correspondant à ce critère. Après chaque exécution, une fenêtre de résumé affiche les anciennes valeurs et les nouvelles valeurs (si l'option "Afficher les résultats" est activée). Par défaut seules sont cochés les champs qui ont été modifiés par le script.

Vous pouvez définir quels champs le script a le droit de modifier via la liste "Champs modifiables".

Si vous cliquez "Sauver" dans la fenêtre de résultats, les nouvelles valeurs des champs cochés seront conservées. Si vous cliquez "Sauver tout", la fenêtre ne s'affichera plus pour les films suivants. Le programme vous demandera si vous désirez qu'il retienne quels champs vous avez cochés pour les films suivants, ou si vous préférez que cela se fasse automatiquement d'après les champs modifiés par le script.

Attention : si l'option "Permettre de vider les champs" est activée, un champ dont la nouvelle valeur est vide mais qui est coché écrasera le contenu précédent.

Le bouton "Ignorer" permet de passer au film suivant et de ne modifier aucun champ pour le film en cours. Le bouton "Arrêter" stoppe l'exécution du script (les films déjà modifiés le restent).

Si l'option "Fermer à la fin" est cochée, la fenêtre de script se refermera, à moins que vous n'ayez cliqué "Arrêter" ou qu'il y ait eu une erreur dans le script.

Si le script le prévoit, différentes options sont affichées dans la liste "Options du script". Double-cliquez sur une option pour la changer.

Lors de l'importation d'internet, si plus d'un film est trouvé (ce qui peut être très courant sur certains sites) vous allez voir une liste vous demandant de sélectionner le bon film. Pour certains scripts vous aurez aussi à choisir parmis plusieurs valeurs possibles pour un champ (par exemple plusieurs résumés de films peuvent être disponibles).

Pour plus de détails à propos de la création de scripts, consultez la page Création de scripts dans la section consacrée aux Informations techniques.


Options

  • Affichage
    • Barre d'outils
  • Fichiers
  • Liste de films
    • Format des titres
  • Informations des films
    • Listes déroulantes
    • Importation de vidéos
    • Importation d'images
    • Recherche sur internet
  • Scripting
  • Exportation
  • Dossiers

Affichage

Icônes : Permet de sélectionner une collection d'iônes qui apparaissent dans les barres d'outils. Ces collections sont des simples fichiers bitmap (".bmp") stockés dans le dossier "Toolbars". Quelques collections sont fournies avec le programme.

Coloration : Spécifie comment les icônes des barres d'outils doivent apparaître lorsque le curseur de la souris n'est pas au-dessus. Les valeurs disponibles sont "Automatique", "Grisées quand inactives" (style Windows 98/2000), "éclaircies quand inactives" (style Office/Windows XP), "Foncées quand inactives" ou "Toujours colorées".

Style Office XP : Donne aux menus et barres d'outils le même aspect que dans Microsoft Office XP.

Images dans les menus : Afficher des images à gauche des éléments des menus. Ces images sont les mêmes que celles utilisées dans les barres d'outils.

Bordure légère pour la liste de films, les informations et le cadre d'image : Lorsque cette option est activée, les éléments spécifiés (de la fenêtre principale) apparaissent avec un bord "moins enfoncé" que par défaut. Cela peut donner mieux si vous utilisez Windows XP avec un thème d'affichage.

Afficher le logo : Le logo de l'application (splash screen) est affiché au démarrage.

Barre d'outils

Vouz pouvez sélectionner quelles icônes doivent être affichées dans la barre d'outils principale. Consultez cette page pour plus d'information sur chaque icône.

Fichiers

Toujours créer une copie de secours : Chaque fois que le catalogue est sauvé, l'ancien est renommé en ".bak".

Au démarrage, ouvrir le fichier suivant ... : Permet de spécifier un fichier à ouvrir plutôt que d'en créer un nouveau. L'option "Réouvrir le dernier fichier utilisé" ouvre le dernier fichier utilisé plutôt que le fichier spécifié.

Nombre de fichiers récents dans le menu : Les derniers fichiers utilisés apparaissent dans le menu "Fichier", au-dessus de la commande "Quitter", pour pouvoir réouvrir ces fichiers rapidement. Vous pouvez sélectionner le nombre de fichiers à y afficher.

Réparer les associations de fichiers : Réécrit dans la base de registres les informations permettant d'ouvrir les fichiers .amc avec ANSYsoft Movie Catalog en double-cliquant dessus.

Stocker l'historique des prêts : Enregistre toutes les entrées/sorties de films dans un fichier texte avec des colonnes délimitées par des tabulations (que vous pouvez donc ouvrir avec des programmes tels que Microsoft Excel). Par défaut le fichier est stocké dans le dossier de l'application, sous le nom "Loans history.csv". Le même fichier est partagé par toutes les instances de Ant Movie Catalog, donc vous pouvez rencontrer des problèmes si vous utilisez la fenêtre de gestion des prêtes dans plusieurs instances (cela sera corrigé plus tard).

Liste de films

Cases à cocher : Si cette option est activée, des cases à cocher sont affichées dans la liste de films dans la fenêtre principale. L'utilisation de cette case à cocher est libre : elles peuvent par exemple servir à indiquer les films vus, les films déjà acquis, ou n'importe quoi d'autre. Ces cases à cocher peuvent servir de filtre pour l'exportation, l'impression et l'exécution de scripts.

Soulignement lors du passage de la souris ("Hot track") : Souligne les éléments des listes lorsque le curseur passe dessus.

Barres de défilement améliorées : Utilise des barres de défilement améliorées pour La fenêtre principale et la fenêtre de gestion des prêts.

Colonne "Numéro de film" : Affiche ou non la colonne contenant les numéros de films à gauche des titres dans la liste principales. Si vous ne vous souciez pas des numéros, cacher cette colonne vous permet de gagner de la place à l'écran.

Ne pas faire de groupes pour les films qui y seraient seuls : Lors de l'utilisation de la fonction "Affichage groupé...", si cette option est activée un groupe n'est créé que s'il y a au moins deux films ayant la même valeur pour le champ sélectionné. Tous les autres films apparaissent ensemble. Cela peut-être assez utile si vous groupez par numéro ou label.

Mettre ces films dans un groupe commun spécial : Crée un groupe "autres" avec ces films plutôt que de les mettre directement dans la liste.

Mettre les films ayant une valeur vide dans un groupe commun spécial : Lors de l'utilisation de la fonction "Affichage groupé...", si cette option est activée un groupe appelé "aucun" est créé pour les films qui n'ont pas de valeur dans le champ choisi pour le groupage.

Afficher le nombre de films de chaque groupe : En mode "Groupé", affiche le nombre de films de chaque groupe près du nom du groupe.

Arborescence ouverte par défaut : Lorsque la fonction "Affichage groupé..." est active, ouvre tous les groupes lors du rafraîchissement de la liste.

Confirmer la suppression : Demande confirmation avant de supprimer un film de la liste.

Confirmer l'annulation : Demande confirmation avant d'annuler les changements apportés à un film.

Touches de raccourci, Film précédent/suivant : Permet de définir une touche de raccourci utilisée pour passer au film précédent ou suivant dans la liste sans que le champ actif ne perde le focus. Ceci est utile lors de la modification d'un champ dans plusieurs films, pour ne pas devoir utiliser la souris pour sélectionner le film suivant. Par défaut les touches sont Ctrl + Page Up/Down, ce qui équivaut à Ctrl + 9/3 du pavé numérique.

Format des titres

Titre à afficher :

  • Titre original : Affiche le titre original uniquement.
  • Titre traduit : Affiche le titre traduit s'il est disponible, sinon le titre original est utilisé.
  • Titre original (Titre traduit) : Affiche d'abord le titre original et ensuite le titre traduit s'il est disponible.
  • Titre traduit (Titre original) : Affiche d'abord le titre traduit et ensuite le titre original. Si le titre traduit n'est pas disponible, seul le titre original est affiché.
  • Label : Affiche le contenu du champ "Label du support".

Placer les préfixes suivant à la fin du titre : Vous pouvez spécifier ici une liste de préfixes qui seront placés à la fin du nom du film (ex. "The Matrix" deviendra "Matrix, The"). Par défaut la liste contient les préfixes anglais et français.
Entrez simplement les préfixes, un par ligne, sans espaces ni apostrophes (un préfixe sera reconnu si, dans le titre du film, il est suivi par un espace ou une apostrophe).
Je n'incluerai pas d'autres langues pour le moment, car cela peut cause des problèmes, ex. "Die" en allemand ("Le") provoquera l'affichage de "Hard, Die" pour le film "Die Hard", ce qui est incorrect. Mais vous pouvez changer les préfixes vous-mêmes pour les ajuster à votre langue.

Informations des films

Demander le numéro : Lors de l'ajout d'un film, une fenêtre vous permettra de choisir le numéro du nouveau film. Si l'option est désactivée le numéro du film sera la valeut par défaut, c'est-à-dire le plus haut numéro + 1, sauf si vous changez l'option suivante :

Utiliser le premier numéro disponible ... : Utilisera le premier numéro disponible plutôt que le plus haut numéro + 1.

Ouvrir la fenêtre "Extraction d'informations ..." : Lors de l'ajout d'un film, la fenêtre de script ou d'importation de fichiers s'ouvrira.

Modifier les valeurs par défaut : Ouvre une autre fenêtre, permettant de modifier les valeurs qui sont pré-remplies lors de l'ajout d'un nouveau film dans la liste.

Note - Ne pas afficher les décimales : Lorsque cette option est activée, la note est affichée comme un nombre entier comme dans les anciennes versions.

Couleur de fond : Permet de sélectionner quelle couleur devra être utilisée pour le fond de la fenêtre d'image. Par exemple, un fond blanc peut donner mieux si les images utilisées sont prévues pour être utilisées sur une page web à fond blanc. La valeur par défaut est BtnFace, qui correspond à la couleur des boîtes de dialogues et des boutons dans Windows.

Adapter la taille de l'image à la fenêtre : Agrandit/Réduit l'image pour éviter d'avoir des barres de défilement dans la fenêtre d'image.

Listes déroulantes

Mêmes options pour toutes les listes : Conserve les options pour toutes les listes.

Tri automatique : Trie par ordre alphabétique le contenu des listes

Auto-complétion lors de la frappe : Si activé, lorsque vous tapez du texte dans une liste déroulante dans la fenêtre principale il y aura une "suggestion" de la valeur dont le début correspond à ce que vous avez tapé, comme lorsque vous tapez une adresse dans un navigateur web. Cela peut causer des problèmes si vous avez plusieurs éléments similaires.

Utiliser les valeurs du catalogue courant plutôt que les listes prédéfinies : N'utilise pas les valeurs entrées pour les listes, mais cherche dans le catalogue courant les valeurs à afficher dans les listes.

Ajouter automatiquement les valeurs qui ne sont pas dans la liste : Si le contenu d'un champ n'est pas dans la liste déroulante de ce champ, la valeur sera ajoutée à la liste (par exemple si vous entrez un pays qui n'est pas dans la liste le programme va l'ajouter à la liste).

Modifier le contenu : Ceci vous permet de modifier le contenu des listes.

Importation de vidéos

Extraction d'infos de fichiers : Spécifie les actions à effectuer lorsqu'un fichier vidéo est déposé sur la fenêtre principale (par exemple à partir de l'Explorateur Windows) or lorsqu'un utilisateur demande à importer les informations de fichiers (depuis le menu).

  • Importer le label du support : Prend le nom de volume du disque sur lequel est le fichier et le copie dans le champ "Label du support".
  • Importer le nom de fichier comme titre : Copie le nom de fichier dans le champ "Titre original".
  • Importer le chemin complet comme adresse : Place le nom de fichier ainsi que son chemin complet dans le champ d'adresse.
  • Importer la taille : Lit la taille des fichiers sélectionnés. La somme peut être calculée ou simplement affichée avec un "+" entre chaque taille, selon l'option choisie.
  • Importer la durée : Lit la durée du fichier (en minutes) et la place dans le champ "Durée".
  • Utiliser le module interne ... : Par défaut, MediaInfo.dll est utilisé pour tous les types de fichiers vidéo à part les AVI, parce que Ant Movie Catalog a son propre module pour cela et qu'il est plus rapide (mais moins précis).

Infos à prendre dans les flux vidéo & audio : Place ces infos dans les champs du même nom. Pour les fichiers AVI, si vous utilisez le module interne, les noms des codecs sont définis dans le fichier "Codecs.ini".

Importation d'images

Importation d'images de l'extérieur : Lorsque vous importez une image, vous pouvez l'associer au film de plusieurs manières :

  • Stocker l'image dans le catalogue : Conserve le fichier d'image dans le catalogue ; cela ne fonctionne que pour les catalogues au format ".amc" et non ".xml". Selon la taille des images, cela peut rendre votre catalogue assez volumineux et donc plus gourmant en mémoire et plus lent à charger. Avec de grandes images cette option n'est donc pas recommandée.
  • Copier l'image vers le dossier du catalogue, et la lier à celui-ci : Copie le fichier d'image dans le dossier où est situé le catalogue et crée ensuite un lien relatif vers l'image (ne stocke donc que le nom de l'image).
  • Seulement lier l'image : Ne stocke que le chemin vers l'image dans le catalogue. L'option "Créer un chemin relatif" peut être utilisée si le dossier du catalogue et celui des images sont assez proches, par exemple si le catalogue est dans "mes documents\catalogues\films.amc" et que les images sont dans "mes documents\mes images\affiches". Cela vous permet de ne pas être dépendant de l'endroit où sont situés les dossiers "catalogues" et "mes images". Par contre, si vous voulez pouvoir déplacer le catalogue sans devoir déplacer les images, il vaut mieux ne pas utiliser les chemins relatifs.

Les mêmes options sont affichées dans la fenêtre de sélection d'image.

La troisième option n'est pas disponible pour l'instant pour les scripts car seuls les liens "locaux" sont supportés (par oppsition aux liens "internet").

Les images stockées dans le même dossier que le catalogue sont supposées "appartenir" au catalogue et sont donc supprimées lorsqu'elles ne sont plus utilisées par un film (par exemple si vous associez une nouvelle image à un film, l'ancienne n'est plus nécessaire). Si vous voulez éviter cela, je vous conseiller de placer manuellement les images par exemple dans un sous-dossier "Images" lorsque vous voulez les ajouter au cataluge, et d'ensuite utiliser les liens relatifs afin que le catalogue et ses images restent "mobiles".

Recherche sur internet

Ceci vous permet de personnaliser le menu "Rechercher sur internet". Il contient les adresses de sites web. Lorsque vous sélectionnez un élément dans le menu, le navigateur par défaut est lancé pour aller sur le site. Le titre du film est inséré à l'endroit où il y a un "%s" dans l'URL.

Les noms doivent être uniques. Si vous voulez insérer un séparateur, vous devez commencer le nom de l'élément par un "-" ; l'adresse est alors ignorée.

Scripting

Retenir le dernier script ... : Recharge le dernier script utilisé, et le sélectionne dans la liste des scripts

Exécuter le script à l'ouverture de la fenêtre : Exécute le script lorsque la fenêtre est ouvert.

Utiliser un proxy pour l'accès à internet : Vous permet de spécifier des informations de connexion à un serveur proxy si nécessaire.

Garder ouverte la connexion au serveur : Par défaut la connexion au serveur est refermée après chaque requête (page ou image). Si cette option est cochée, la connexion ne sera pas automatiquement fermée. Cela peut améliorer un petit peu les performances lors de la récupération de fichiers venant du web, mais je le laisse en tant qu'option car beaucoup de personnes avaient des problèmes lorsque la connexion restait ouverte. Si vous obtenez des messages d'erreur similaires à "Connection closed gracefully" lorsque l'option est activée, ne l'utilisez pas.

Exportation

Recharger automatiquement le dernier modèle utilisé : Conserve le nom du dernier modèle utilisé, pour le recharger la prochaine fois que la fenêtre est affichée.

Les "retour à la ligne" seront remplacés par ... : Permet de modifier le tag utilisé lors de l'insertion d'un retour de ligne. étant donné qu'il s'agit du seul tag que le programme ne prend pas dans le modèle, vous pouvez le définir ici. Si vous utilisez du HTML vous choisirez probableemnt le tag par défaut <br>, mais vous pouvez vouloir <br /> pour du XHTML ou XML. Vous pouvez aussi simplement laisser ce champ vide si vous ne voulez pas que les retour à la ligne soient remplacés par quelque chose d'autre.

Forcer la taille de l'image avec les attributs : Permet de spécifier une valeur pour les attributs HTML height et width. Si vous laissez un de ces champs vide (ou les deux), l'attribut ne sera pas ajouté.

Format de la date SQL : Permet de définir quel format utiliser pour la date lors de l'exportation SQL. Si vous laissez ce champ vide, le format de date court défini dans Windows sera utilisé. Les caractères pour le masque sont utilisés dans Delphi : yy et yyyy = année (sur 2 ou 4 chiffres), m et mm = mois (sans ou avec le zéro non significatif), d et dd = jour (sans ou avec le zéro non significatif), et les caractères devant rester inchangés doivent être placés entre apostrophes (ex : yyyy'/'mm'/'dd).

Retenir le nom du dernier fichier exporté : Utilise le nom du dernier fichier exporté plutôt que le nom du catalogue.

Ouvrir le fichier créé ... : Lance le fichier après exportation

Style des noms des pages individuelles et des images : Permet de spécifier comment le programme doit créer les noms des multiples fichiers qui accompagnent le fichier exporté.

Exemple, si vous exportez le fichier "Mes films.amc" vers "Ma liste.html":

Fichier exporté + Numéro de film | Num du catalogue + Numéro de film | Titre du film
ma liste.html | ma liste.html | ma liste.html | Liste complète
ma liste_1.html | mes films_1.html | matrix.html | Premier film
ma liste_2.html | mes films_2.html | starwars - episode one.html | Deuxième film
etc...

Extension à ajouter : Permet de forcer une autre extension pour les fichiers individuels. Ceci peut être utile si par exemple votre liste principale est un fichier .html, mais que vous voulez des fichiers .php pour chaque fiche de film individuelle. Si le champ est vide l'extension du fichier principal est utilisée pour les fichiers individuels.

Ajouter des zéros devant les petits nombres : si activée, des zéros seront ajoutés à gauche du nombre si nécessaire afin d'avoir un tri correct dans tous les gestionnaires de fichiers (seul l'Explorateur de Windows XP semble détecter les nombres dans les noms lors du tri).

Copier les images dans le même dossier que le fichier créé : Extrait ou copie les images du catalogue vers le même dossier que le fichier exporté.

Copier uniquement si le fichier de destination n'existe pas : Si l'option est activée, l'image d'un film ne sera pas copiée si une image du même nom existe déjà (seul le nom est comparé, donc l'image ne sera pas écrasée même si elle est différente).

Dossiers

Vous pouvez définir ici le comportement des boîtes de dialogue de sélection de fichier pour :

  • Ouverture et sauvegarde des catalogues (Load/save catalogs)
  • Sélection d'une image (Load movie picture)
  • Exportation
  • Ouverture et sauvegarde des modèles (Load/save templates)
  • Importation
  • Extraction d'infos de fichiers
  • Sauvegarde du grapgique
  • Ouverture et sauvegarde des scripts

L'option "Mêmes options pour toutes les fenêtres" permet de définir le même dossier par défaut pour toutes les fenêtres.


Barres d'outils

Tous les éléments du menus sont disponibles en tant qu'icônes pour barres d'outils. Par défaut, le programme affiche les fonctions les plus courrantes dans la barre d'outils. Vous pouvez modifier cela via la fenêtre des Options.

Fichier

Nouveau : Crée un nouveau catalogue.

Ouvrir : Charge un catalogue. Il y a deux icônes "Ouvrir". La seconde affiche une petite flèche à sa droite, permettant d'afficher la liste des fichiers ouverts récemment.

Sauver : Sauve le catalogue sous le nom de fichier courrant.

Sauver sous : Sauve le catalogue sous un nouveau nom.

Imprimer : Affiche la fenêtre de prévisualiation des rapports.

Importer : Permet d'importer des enregistrements d'autres formats de fichiers.

Exporter : Permet d'exporter le catalogue vers d'autres formats de fichiers.

Propriétés : Affiche des informations sur le fichier courant et sur le catalogue.

Quitter : Quitte le programme.

Film

Ajouter : Ajoute un film dans la liste.

Changer le numéro : Permet de modifier le numéro du film sélectionné.

Supprimer : Supprime le film courant.

Rechercher : Cherche un film sur la base d'un champ spécifié.

Afficher l'image : Affiche ou cache la fenêtre d'image.

Fonctions d'image : Affiche un sous-menu avec les icônes suivantes...

Sélectionner : Sélectionne une image qui sera stockée ou liée au catalogue et associée à ce film.

Sauver l'image : Sauve une copie de l'image dans un fichier (uniquement pour les images stockées, pas encore disponible pour les images liées).

Copier : Copie l'image dans les presse-papiers au format bitmap.

Supprimer : Supprimer l'image du film courant.

Dock/Undock : Change le style de la fenêtre d'image, "docké" (integré à la fenêtre principale) ou "undocké" (fenêtre flottante).

Copier : Copie toutes les informations du film courant vers le presse-papiers.

Coller : Utilises les informations stockées dans le presse-papiers pour le film courant.

Annuler : Recharge les information du film courant. Ces informations sont sauvées lorsque le catalogue est sauvé ou lorsque l'on sélectionne un autre film.

Extraire des infos : Affiche un sous-menu avec les fonctions d'importation suivantes...

De fichiers : Permet de sélectionner des fichiers et d'en extraire des informations (fichiers vidéo ou images). Le résultat est le même que lorsque l'on "drag & drop" des fichiers sur la fenêtre principale.

D'un script : Affiche la fenêtre de script, permettant d'utiliser un fichier de script pour importer des informations de film via internet..

Rechercher sur internet : Affiche un menu (personnalisable par l'utilisateur) permettant de lancer le navigateur web pour rechercher des informations d'un film sur internet.

Outils

Affichage groupé : Groupe les films dans la liste d'après la valeur d'un champ spécifié.

Afifchage en tableau : Affiche la liste de films sous forme d'une large liste avec les films et toutes leurs informations.

Scriping : Affiche la fenêtre de script, permettant d'appliquer un script à une liste de films.

Renuméroter : Renumérote les films, en commançant à 1 avec des chiffres continus. Ceci vous permet de combler les trous apparaissant lorsque vous supprimez des films si vous n'avez pas besoin de conserver des numéros fixes pour chaque film.

Prêts : Liste de tous les films actuellement en prêt, et qui a quel film.

Statistiques : Affiche des graphiques à propos du catalogue.

Options : Permet de modifier les options du programme.

Langue : Change la langue des fenêtres du programme.

Aide

Aide : Affiche ce fichier d'aide.

À propos de : Affiche des informations à propos de l'auteur du programme et la version.


Informations techniques

Vous trouverez ici quelques informations techniques à propos de Ant Movie Catalog :

  • Fichiers de traduction
  • Format des fichiers de catalogue
  • Création de scripts
  • Création de rapports (modèles pour l'impression)


Fichiers de traduction

Les fichiers de traduction utilisent une syntaxe proche de celle des fichiers INI. Ils s'agit de simples fichiers texte, que vous pouvez donc modifier avec n'importe quel éditeur texte, comme le Bloc-Notes de Windows.

Le fichier contient des sections. Une section est un nom entre crochets. Les noms de sections correspondent aux noms des fenêtres de l'application.

ex. : [MainWindow]

En-dessous de cela, vous trouvez les éléments correspondants à la fenêtre spécifiée. Ces items sont des paires attributs/valeurs.

ex. : Attribute=Value

Les attributs correspondent au chemin version le composant à traduire, et les valeurs au nouveau texte à afficher. Le chemin est construit avec le nom du composant, un point, puis la propriété à modifier ("composant.propriété"). Pour certains éléments il y a un composant dans un autre composant. Parfois il s'agit de tableaux d'éléments, donc il y a un numéro d'index entre crochets. Pour les propriétés des fenêtres il y a juste un nom de propriété tout seul.

ex. pour la section [ExportWin] :

Caption=Export to another file format // titre (caption) de la fenêtre d'exportation
btn1.Caption=Help // titre (caption) du premier bouton de la fenêtre d'exportation
Messages.Strings.String[0]=Unable to save // premier message de la liste de messages de la fenêtre d'exportation

Les noms de composants utilisent des noms "standard".

Les boutons commencent par "btn", les actions (items de menus & barres d'outils) commencent par "Action", les cases à cocher (checkbox) commencent par "CB", les boutons radio commencent par "RB", les labels commencent par L ou LH, les champs d'édition commencent par E, etc...

La fenêtre de dialogue de base peut avoir de 0 à 4 boutons, appelés btn1, btn2, btn3, btn4 ; où btn1 est le bouton dans le coin inférieur droit.

Une ligne de commentaire commence par un point-virgule (;) et est ignorée par le programme.

Il y a une section spéciale, qui est utilisée pour afficher des informations dans la fenêtre de sélection de la langue :

[FileInformation]
Icon= Une image bitmap en 16x16 (couleurs 4 bits), encodée MIME
Name= Nom de la langue, en anglais
LocalName= Nom de la langue traduite dans la langue elle-même
Version= Version du programme pour laquelle le contenu a été traduit (si inférieur à VersionFormat, cela signifie qu'il y a des parties encore en anglais)
VersionFormat= Version du programme pour laquelle la structure du fichier a été faite
Comments= Texte libre (retour à la ligne = "|", lien = <link>adresse</link>)
Authors= Noms et adresses e-mail des traducteurs (chaque nom/adresse est séparé par un "|" : nom1|adr1|nom2|adr2)

Si vous voulez être averti des erreurs de traduction, vous pouvez démarrer le programme avec le paramètre /tr_show_errors.


Format des fichiers de catalogue ".amc"

Notes

Tous les types sont les types du langage Pascal, étant donné que le programme est créé avec Delphi.

Tous les champs "string" (chaînes) sont précédés d'un entier (4 octets, signé) donnant la taille du vecteur (taille = 0 si pas de vecteur, c.à.d. une chaîne vide). Les chaînes sont donc des vecteurs de caractères (1 caractère = 1 octet, non signé) sans délimiteur de fin.

Le champ "Picture" est un vecteur d'octets, contenant l'image dans son format d'origine (PNG/JPEG/GIF).
Son type est donné par le champ "PictureName" qui le précède.
Si la taille de l'image est > 0, alors PictureName contient l'extension originale du fichier ('.png', .'.jpg' ou '.gif'). Si la taille de l'image = 0 alors PictureName contient un lien vers l'image (absolu ou relatif), ou rien du tout s'il n'y a aucune image associée au film courant.

Version 3.3

En-tête :

strFileHeader35 = ' AMC_3.5 Ant Movie Catalog 3.5.x   www.buypin.com    www.antp.be ';
OwnerName:          string;
OwnerSite:          string;
OwnerMail:          string;
OwnerDescription:   string;

Structure d'un film, répétée pour chaque film :

Number:           Integer;
Date:             Integer;
Rating:           Integer;
Year:             Integer;
Length:           Integer;
VideoBitrate:     Integer;
AudioBitrate:     Integer;
Disks:            Integer;
Export:           Boolean;
Media:            string;
MediaType:        string;
Source:           string;
Borrower          string;
OriginalTitle     string;
TranslatedTitle   string;
Director          string;
Producer          string;
Country           string;
Category          string;
Actors            string;
URL               string;
Description       string;
Comments          string;
VideoFormat       string;
AudioFormat       string;
Resolution        string;
Framerate         string;
Languages         string;
Subtitles         string;
Size              string;
PictureName:      string;
PictureSize:      Integer;
Picture           array of Byte;

Les seules changements depuis la version 3.5 sont la suppression du champ ICQ de l'en-tête et le passage de la Note (Rating) en format 0-100 plutôt que 0-10 (le dernier chiffre étant utilisé pour la partie décimale). La version 3.4 utilisait le même format de fichier que la version 3.3.


Création de scripts

  • Constantes
  • Fonctions/Procédures
  • Classes
  • Propriétés des scripts
  • Outils de débogage

Ces scripts sont de simples fichiers texte, donc vous pouvez les modifier avec n'importe quel éditeur texte. Mais l'utilisation de l'éditeur intégré à Ant Movie Catalog permet de facilement éditer l'en-tête du script via la fenêtre des propriétés.

Le langage utilisé ici un dérivé du Pascal et de Delphi. Si vous n'avez jamais utilisé de Pascal mais que vous connaissez un autre language (C, C++, PHP, Java ou autre), il ne sera probablement pas trop difficile pour vous de l'apprendre en observant les scripts existants.

Le moteur de script utilisé est Innerfuse Pascal Script de Carlo Kok's, dans sa version 2.

La plupart des fonctions de base sont supportées. Il y a également une série de fonctions et constantes destinées à l'échange de données avec Ant Movie Catalog. Cette page les décrit.

Le script commence par un bloc de commentaires, qui n'est pas visible lorsque le script est ouvert avec l'éditeur de Ant Movie Catalog. Ce bloc contient les différents paramètres modifiables via la fenêtre des propriétés.

Seuls les scripts placés dans le dossier "Scripts" seront affichés automatiquement dans la liste.

Constantes

Ces constantes sont les identifiants des champs, utiles lorsque vous voulez écrire ou lire la valeur d'un champ du film :

fieldNumber
fieldChecked
fieldMedia
fieldMediaType
fieldSource
fieldDate
fieldBorrower
fieldRating
fieldOriginalTitle
fieldTranslatedTitle
fieldDirector
fieldProducer
fieldCountry
fieldCategory
fieldYear
fieldLength
fieldActors
fieldURL
fieldDescription
fieldComments
fieldVideoFormat
fieldVideoBitrate
fieldAudioFormat
fieldAudioBitrate
fieldResolution
fieldFrameRate
fieldLanguages
fieldSubtitles
fieldSize
fieldDisks

Autres constantes :

dirApp: string; contient le dossier du programme
dirScripts: string; contient le dossier dans lequel sont les scripts

Fonctions/Procédures générales

function Input(caption, prompt: string; var value: string): Boolean;
Affiche une fenêtre, permettant à l'utilisateur d'entrer un texte. Retourne True si l'utilisateur clique sur OK, False si l'utilisateur clique sur Cancel.

function GetPage(address: string): string;
Télécharge une page HTML (ou autre fichier texte) via la méthode GET et la retourne sous forme de chaîne.

function GetPage2(address: string; referer: string): string;
Idem que GetPage, mais permet de donner une adresse de "referer" (la page depuis laquelle on appelle la page suivante).

function PostPage(address: string; params: string): string;
Télécharge une page HTML (ou autre fichier texte) via la méthode POST et la retourne sous forme de chaîne. Les paramètres doivent être encodés par la fonction URLEncode.

function PostPage2(address: string; params: string; content: string; referer: string; forceHTTP11: Boolean; forceEncodeParams: Boolean): string;
Idem que PostPage, mais permet de spécifier en plus le content-type (au lieu de 'application/x-www-form-urlencoded'), donner une adresse de "referer", forcer l'utilisation de HTTP 1.1 (au lieu de 1.0) et demander à la fonction d'encoder elle-même les paramètres.

procedure GetPicture(address: string);
Télécharge une image et l'associe au film courant.

procedure HTMLDecode(var Value: string);
Décode les caractères HTMLc ontenus dans la chaîne "Value" (ex. "&eacute;" -> "é").

function URLEncode(source: string): string;
function URLDecode(source: string): string;
Convertit les caractères en paramètres d'URL (ex. " " -> "%20") et vice versa.

function GetField(field: Integer): string;
Lit et retourne la valeur du champ spécifié du film courant.

procedure SetField(field: Integer; value: string);
Stocke la valeur dans le champ spécifié du film courant.

function CanSetField(field: Integer): Boolean;
Permet au script de savoir si le champ spécifié est coché ou non dans la liste des champs modifiables. Le script n'a normalement pas à s'en soucier car un SetField d'un champ sera inactif si le champ n'est pas coché, mais cette fonction permet d'éviter par exemple de télécharger une page supplémentaire dans le cas où un certain champ ne doit de toute façon par être récupéré.

function CanSetPicture: Boolean;
Similairement à CanSetField, indique si le script peut récupérer une image.

function GetOption(OptName: string): Integer;
Retourne la valeur que l'utilisateur a choisi pour l'option spécifiée. Les noms d'options et leurs valeurs possibles sont définis dans la fenêtre des propriétés.

function StringReplace(S, Old, New: string): string;
Remplace Old par New dans S, et retourne le résultat (S n'est pas modifié). Utilisez #13#10 (sans guillemets) pour remplacer les retour de ligne.

procedure Error;
Interrompt l'exécution du script.

procedure Sleep(ATime: Integer);
Attend pendant le nombre spécifié de millisecondes (utile pour éviter les erreurs de connexion au serveur lors des importation en masse).

function CheckVersion(Major, Minor, Revision: Integer): Boolean;
Renvoie True si la version courante du programme est égale au supérieure à la version spécifiée dans les paramètres.

procedure Launch(command: string; parameters: string);
Lance un fichier externe, pouvant être un programme, un fichier, ou une adresse web. La valeur de "parameters" peut être une chaîne vide : ''.

function AnsiUpperCase(Value: string): string;
Convertit toutes les lettres de la chaîne en majuscule. *

function AnsiLowerCase(Value: string): string;
Convertit toutes les lettres de la chaîne en minuscule. *

function AnsiUpFirstLetter(Value: string): string;
Convertit la première lettre de la chaîne en majuscule. Les autres restent inchangées. *

function AnsiMixedCase(Value: string; Delimiters: string): string;
Convertit toutes les lettres suivant une lettre de "Delimiters" en majuscule (la première lettre est aussi convertie). Les autres lettres restent inchangées. *
Le paramètre "Delimiter" est une chaîne contenant les caractères devant être suivi d'une majuscule, ex : ' -' créera "This Is A Sample-Text".

* Les lettres accentuées sont aussi converties, selon les paramètres régionnaux définis dans Windows.

function UTF8Encode(Value: string): string;
function UTF8Decode(Value: string): string;
Convertit une chaîne classique en UTF8 (unicode) et vice versa. L'unicode n'était pas réellement supporté (utilisation de "string" et non "WideString"), seuls les caractères disponibles dans le jeu de caractère courant seront conservés.

function AcceptLicense(LicenseVersion: Integer): Boolean;
Affiche dans une fenêtre le contenu du champ "Licence" du script tel que défini dans la fenêtre des propriétés avec des boutons "J'accepte" et "Annuler". Lorsque l'utilisateur a accepté la licence, il ne doit plus la réaccepter jusqu'à ce que le numéro de licence passé en paramètre change. Cela permet de réafficher la fenêtre chez tous les utilisateurs lorsque la licence est modifiée, tout en ne les ennuyant pas à chaque exécution du script.

procedure SetStatic(AName: string; AValue: string);
function GetStatic(AName: string): string;
Permet de lire/écrire une variable "permanente" : la valeur assignée à cette variable virtuelle sera conservée à travers les différentes exécutions du programme, contrairement à une variable globale dont la valeur est perdue lorsque l'exécution du script sur les films sélectionnés est terminée.

procedure ShowMessage(message: string);
Fenêtre "neutre" affichant simplement le message.

procedure ShowError(message: string);
Fenêtre d'erreur (icône de "x" sur un cercle rouge).

procedure ShowInformation(message: string);
Fenêtre d'information (icône de "i" dans une bulle).

function ShowWarning(message: string): Boolean;
Fenêtre d'avertissement (icône de "!" sur un triangle jaune), avec boutons OK (retourne True) et Annuler (retourne False).

function ShowConfirmation(message: string): Boolean;
Fenêtre de confirmation (icône de "?" dans une bulle), avec boutons Oui (retourne True) et Non (retourne False).

Fonctions de la fenêtre "PickTree"

Cette fenêtre affiche une arborescence, typiquement pour afficher la liste des films trouvés sur le site.

procedure PickTreeClear;
Vide le contenu de la fenêtre - Applez cette fonction avant d'utiliser la fenêtre car elle n'est jamais vidée automatiquement.

procedure PickTreeAdd(Caption, Address: string);
Ajoute un nouvel élément a la fenêtre. Si l'adresse est une chaîne vide ou si la fenêtre est vide, l'élement est ajouté au niveau racine. Sinon il est ajouté en tant qu'élément "enfant". L'adresse est la chaîne retournée par la fenêtre lorsque l'utilisateur sélectionne l'élément.

procedure PickTreeMoreLink(Address: string);
Initialise l'adresse pointée par le bouton "Find More" de la fenêtre PickTree. Cette valeur est effacée par la fonction PickTreeClear, et le bouton est désactivé s'il n'est pas initialisé par PickTreeMoreLink.

function PickTreeExec(var Address: string): Boolean;
Affiche la fenêtre. Le paramètre Address contiendra l'adresse correspondant à l'élément sélectionné. La fonction renvoie True si l'utilisateur clique sur OK, False si l'utilisateur clique sur Cancel.

Fonctions de la fenêtre "PickList"

Cette fenêtre affiche une simple liste, typiquement pour afficher une liste de valeurs disponibles pour un champ (comme la description ou les commentaires). Il y a une grande zone de texte pour afficher l'élement sélectionné.

procedure PickListClear;
Vide le contenu de la fenêtre - Applez cette fonction avant d'utiliser la fenêtre car elle n'est jamais vidée automatiquement.

procedure PickListAdd(Text: string);
Ajoute un nouvel élément à la fenêtre.

function PickListExec(WelcomeText: string; var Selected: string): Boolean;
Affiche la fenêtre. Le paramètre WelcomeText est le texte affiché dans la zone du bas de la fenêtre lorsqu'aucun élément n'est sélectionné. Le paramètre Selected contiendra le texte de l'élément sélectionné. La fonction renvoie True si l'utilisateur clique sur OK, False si l'utilisateur clique sur Cancel.

Classe TStringList

TStringList est une classe qui peut être utilisée pour gérer une liste de chaînes. Elle peut être utile pour la gestion des pages web, étant donné qu'elle permet de facilement accéder aux lignes séparément.

Déclaration : aList: TStringList;
Création : aList := TStringList.Create;
Destruction : aList.Free;

Les méthodes et propriétés suivantes sont disponibles :
procedure LoadFromFile(FileName: string); charge un fichier texte dans la liste
procedure SaveToFile(FileName: string); sauve le contenu vers un fichier texte
function GetString(LineNr: string): string; lit une ligne
procedure SetString(LineNr: string); écrit une ligne
function Count: string retourne le nombre de lignes de la liste
property Text: string; permet de lire ou écrire la liste complète comme une simple chaîne (utilisé par lea fonction GetPage par exemple)

Classe TJvSimpleXml et classes liées

Il s'agit d'un parseur XML assez complet, permettant de manipuler des documents XML plus facilement. Toutes ses fonctionnalités ne sont pas accessibles via les scripts, il se peut donc que la liste suivante soit complétée lorsque certaines fonctionnalités soient rajoutées au moteur de script.

La création de l'objet se fait de manière similaire à la TStringList présentée ci-dessus.

Il possède les méthodes et propriétés suivantes :
procedure LoadFromString(Value: string); charge un document XML à partir d'une chaîne
procedure LoadFromFile(FileName: string); charge un document XML à partir d'un fichier
procedure SaveToString: string; stocke le document XML courant dans une chaîne
procedure SaveToFile(FileName: string); stocke le document XML courant dans un fichier
property Root: TJvSimpleXmlElemClassic; élément correspondant au nœud "racine" du document XML

Les différents nœuds du document sont des TJvSimpleXmlElemClassic, dérivant de TJvSimpleXmlElem. Ce dernier possède les méthodes et propriétés suivantes :
property Name: string; nom du nœud : <nom>
property Value: string; valeur du nœud : <nom>valeur</nom>
property Items: TJvSimpleXmlElems; liste des sous-éléments du nœud
property Properties: TJvSimpleXmlProps; liste des propriétés (attributs) du nœud : <nom attr1="val1" attr2="val2">
property Parent: TJvSimpleXmlElem nœud parent
function GetChildIndex(AChild: TJvSimpleXmlElem): Integer; position dans la liste (Items) du nœud "enfant" spécifié
procedure Clear; supprime tous les éléments et propriétés du nœud

La classe TJvSimpleXmlElems possède les méthodes et propriétés suivantes :
property Count: Integer retourne le nombre d'éléments de la liste
function GetItem(Index: Integer): TJvSimpleXmlElem; permet d'accéder à un élément de la liste en spécifiant sa position
function GetItemNamed(Name: string): TJvSimpleXmlElem; permet d'accéder à un élément de la liste en spécifiant son nom
procedure Clear; supprime tous les éléments de la liste
procedure Delete(Index: Integer); supprime l'élément à la position spécifiée
procedure DeleteNamed(Name: string); supprime l'élément ayant le nom spécifié
function Add(Name: string): TJvSimpleXmlElemClassic; crée et ajoute à la liste un élément

Les attributs de chaque nœud sont des TJvSimpleXmlProp, possédant les propriétés suivantes :
property Name: string; nom de l'attribut
property Value: string; valeur de l'attribut

Ceux-ci sont stockés et gérés par la classe TJvSimpleXmlProps, possédant les méthodes et propriétés suivantes :
property Count: Integer; retourne le nombre de propriétés de la liste
function GetItem(Index: Integer): TJvSimpleXmlProp; permet d'accéder à une propriété de la liste en spécifiant sa position
function GetItemNamed(Name: string): TJvSimpleXmlProp; permet d'accéder à une propriété de la liste en spécifiant son nom
procedure Clear; supprime toutes les propriétés de la liste
procedure Delete(Index: Integer); supprime la propriété à la position spécifiée
procedure DeleteNamed(Name: string); supprime la propriété ayant le nom spécifié
function Add(Name: string; Value: string): TJvSimpleXmlProp; crée et ajoute à la liste une propriété

Propriétés des scripts

Le titre, la description et tous les autres attributs/paramètres des scripts peuvent être définis via cette fenêtre. Elle est accessible par l'icône [image] "Propriétés" de l'éditeur de scripts.

Le titre du script doit être relativement court ; il s'agit a priori du nom du site duquel les informations sont importées. Le champ "Infos d'Internet" indique si le script sert à importer des informations d'internet. Seuls les scripts ayant ce champ à "True" sont visibles lorsque la fenêtre de script est appelée via "Extraire des informations" -> "D'Internet via un script". Lorsque la fenêtre est appelée via le menu "Scripting" tous les scripts sont affichés.

Pour chaque option que vous définissez, vous devez définir ses différentes valeurs possibles (nombre entiers positifs, associés à une description).

Outils de débogage

La barre d'outils visible dans l'éditeur de script possède des commandes similaires à celles disponibles dans Delphi :

  • Basculement de point d'arrêt : place un point d'arrêt sur la ligne en cours pour que l'exécution du script soit mise en pause avant exécution de cette ligne. La ligne apparaît avec un fond rouge. Vous pouvez également placer un point d'arrêt en cliquant dans la marge gauche de l'éditeur. Seuls les points d'arrêts placés sur des lignes de code valides seront utilisés. Il n'est malheureusement pas possible d'indiquer visuellement quels sont les point d'arrêts invalides comme le fait Delphi lors de l'exécution d'un programme. Lorsque l'exécution est en pause, vous pouvez avancer à l'instruction suivante manuellement via le bouton "Avancer" ou relancer l'exécution via le bouton "Exécuter".
  • Supprimer les points d'arrêt : supprime en un coup tous les points d'arrêts définis dans le script.
  • Avancer : exécute la ligne en cours (surlignée en bleu) et passe à l'instruction suivante.
  • Exécuter jusqu'au curseur : exécute le script jusqu'à ce qu'il arrive à la ligne courante (génère donc un point d'arrêt "virtuel").
  • Évaluer la variable : affiche le contenu de la variable qui est à la position du curseur.
  • Ajouter un suivi de cette variable : rajoute à la liste de suivis la variable à la position du curseur. Cela permet de connaître à tout moment le contenu de la variable.


Ant Movie Catalog - Aide

Création de rapports (modèles pour l'impression)

Pour lancer le Report Designer, cliquez sur le bouton "Ouvrir le Designer" dans la fenêtre d'impression. Vous pouvez aussi utiliser le raccourci qui a été ajouté dans le Menu Démarrer, ou encore lancer AMCReport.exe qui est situé dans le même dossier que Ant Movie Catalog.

Ce Designer est celui de FreeReport, et n'a presque pas été modifié (il est plutôt complexe, je vais donc probablement le laisser tel qu'il est actuellement).

Cette page montre les différentes étapes de la création d'un rapport.

Sélection de la taille de la page

Allez dans File -> Page Options pour sélectionner la taille du papier. En général ce sera A4 (ou Letter). Vous pouvez aussi sélectionner l'orientation Lanscape (Paysage) à la place de Portrait si vous voulez. Dans cette fenêtre vous pouvez également choisir le nombre de colonnes que vous désirez avoir sur votre page.

Bandes

Pour être reconnus, les champs doivent être placés sur des "Bands" (bandes). Pour mettre une bande sur la page, cliquez sur l'icône Band band et ensuite cliquez sur la page, là où vous voulez placer la bande. Ensuite vous pouvez sélectionner quel type de bande il faut placer :

Certains types ne seront jamais utilisés ici. Ceux que vous allez probablement utiliser sont :

  • Report title & Report summary : Titre et résumé du rapport ; n'apparaissent que sur la première page
  • Page header & Page footer : En-tête et pied de page de chaque page
  • Master data : Ceci est la bande la plus importante, c'est celle qui sera répétée pour chaque film

Sélectionnez "Master data" et cliquez "OK". Une autre fenêtre vous demandera de sélectionner la source, laissez le choix par défaut ("None") et cliquez "OK".

Zones de texte

Pour placer une zone de texte sur la bande Master data, sélectionnez l'icône Rectangle object rectangle et placez-le sur la bande (attention: ne le placez pas en-dehours de la bande, où il risque de ne pas apparaître sur le rapport final).

L'éditeur de texte est affiché :

Vous pouvez entrer le texte que vous voulez, puis cliquer "OK". Pour accéder à nouveau à cette fenêtre, double-cliquez sur une zone de texte.

Dans le menu contextuel (clic de droite) de ces objets, il y a trois options :

  • Stretched : Si activé, la hauteur du dernier champ sera augmentée si nécessaire. Cela ne semble pas fonctionner pour les autres champs.
  • Word wrap : Force un retour à la ligne si le texte est plus large que le champ.
  • Autosize : Augmente la largeur du champ si nécessaire.

Variables (champs des films et autres)

Pour placer un champ de film, ajoutez une zone de texte (Rectangle object). Dans ses propriétés, spécifiez le nom du champ entre crochets [ ]. La liste des noms de champs est disponible via le bouton "Variables" de la fenêtre d'édition de texte :

Les noms de champs peuvent eux-aussi être obtenus via des variables. Il suffit de mettre le préfixe "label:" devant le nom de la variable, le tout étant entre crochets. Cela permet de faire des rapports multilingues (qui s'adaptent à la langue dans laquelle le programme est utilisé).

Dans la liste déroulante vous pouvez sélectionner "Other" pour voir les champs spéciaux tels que le numéro de page, la date, etc...

Vous pouvez mélanger du texte normal et des variables dans une même zone de texte.

Images

Pour placer une image, utilisez l'icône Insert picture [image]. La fenêtre d'image ressemble à ceci :

Si vous voulez que cette image affiche l'image du film courant, cliquez sur le bouton "Memo" et entrez "[Picture]" (ou sélectionnez-le dans la liste des variables).

Dans le menu contextuel de la zone d'image, il y a trois options :

  • Stretched : Redimensionne l'image pour qu'elle ne dépasse pas de l'objet
  • Center picture : Centre l'image dans l'objet
  • Keep aspect ratio : Conserve les proportions de l'image

Vous pouvez aussi dessiner des lignes, via l'icône Draw line lines.

Scripts

Dans la fenêtre d'édition du contenu des zones de texte et des images, une option "Script" peut être cochée. La partie inférieure de la fenêtre vous permet alors d'entrer un script. Les scripts utilisés ici n'ont rien à voir avec ceux utilisés par Ant Movie Catalog, mis à part que le language utilisé est lui-aussi basé sur du Pascal. Voici quelques exemples :

  • Si vous désirez ne faire apparaître une image que pour les films d'action, placez le code suivant dans la partie "Script" du memo de l'image :

    begin
  Visible := [Category] = 'Action';
end;

  • Si vous désirez placer l'année entre parenthèses derrière le titre seulement si elle est spécifiée pour le film (pour éviter de se retrouver avec des parenthèses vides), placez le code suivant dans la partie "Script" d'une zone de texte :

    begin
if ([Year] <> '') then
  tmp1 := [OriginalTitle] + ' (' + [Year] + ')'
else
  tmp1 := [OriginalTitle]
end;

    Placez ensuite dans la zone de texte le code [tmp1] pour utiliser le résultat du script comme étant une nouvelle variable.

Beaucoup de fonctions du Report Designer ne sont pas utilisées ici, comme par exemple les champs DB, l'aperçu avant impression (Print Preview), les Subreports, ... (pour l'aperçu avant impression, sauvez le modèle et cliquez ensuite sur "Rafraîchir" dans la fenêtre d'impression de Ant Movie Catalog, une fois que le bon modèle est choisi dans la liste bien sûr).

Si vous avez des problèmes avec des champs de films, assurez-vous qu'ils sont placés sur une bande "Master data". Si des champs tels que "Total pages" ne fonctionnent pas, assurez-vous que l'option "Two pass report" est activée dans File -> Report Options.


Historique des versions

  • 3.5.0 (13/03/2005)
    • Lien vers MediaInfo.dll pour importer les informations de fichiers autre que les AVI : OGM, MKV, RM, WMV, DVD (IFO/VOB).
    • Remaniement de la fenêtre de scripts. Maintenant les scripts peuvent définir des options qui pourront facilement être changées par les utilisateurs. Ceux-ci peuvent également spécifier quels champs peuvent être modifiés. Quelques nouvelles fonctions pour les scripts ainsi qu'un parseur XML ont été ajoutés. La fenêtre des résultats a aussi été refaite.
    • Fonctionnalités de débogage pour les scripts : exécution pas à pas, points d'arrêt, liste des suivis, etc.
    • Le moteur de script peut maintenant utiliser des fichiers externes : lorsque vous placez un nom d'unité dans les "uses" d'un script il ira chercher un fichier ayant de ce nom-là avec une extension .pas ou .ifs dans le même dossier.
    • Les boutons pour importer et pour lier une image ont été réunis en un seul, des boutons radio affichés dans la fenêtre de sélection d'image permettent de choisir que faire de l'image. Des options ont été ajoutées dans la fenêtre des Options pour spécifier si vous préférez stocker ou lier les images, il n'est donc plus nécessaire de modifier les scripts pour cela.
    • Les fenêtres d'Exportation, Impression et Statistiques ont maintenant une option pour prendre en compte tous les films, ou juste ceux qui sont sélectionnés, cochés ou visibles.
    • Fenêtre séparée pour le choix de la langue, affichée lors du premier démarrage du programme ; j'espère que je recevrai moins d'e-mails de personnes me demandant comment avoir le programme en français ;)
    • Champ virtual "Titre formaté" qui peut être utilisé pour les tris, il est donc maintenant possible de trier proprement sur le titre traduit. Le champ "Coché" (cases à cocher dans la liste de la fenêtre principale) a été également ajouté à la liste des champs disponibles.
    • Le champ "Note" possède maintenant un chiffre après la virgule comme sur IMDB.
    • Les noms de champs peuvent être utilisés dans les rapports imprimés, de manière à être traduits eux aussi (utilisation : [label:nomchamp] où "nomchamp" est le même que celui que vous utiliseriez pour afficher une des valeurs de film).
    • Les doublons dans les numéros de films sont acceptés (et pour ceux qui veulent toujours des numéros uniques, j'ai ajouté dans la fenêtre d'Ajout de film quelques actions disponibles lorsque le nouveau numéro existe déjà).
    • Groupage : une option a été ajoutée pour mettre ensemble les films qui étaient seuls dans leur groupe. Cela peut être très utile si vous groupez les films par numéro ou par label.
    • Quelques raccourcis ont été modifiés dans la fenêtre principale afin de les rendre plus logiques.
    • Énormément de petites corrections et améliorations.
  • 3.4.3 (28/02/2004)
    • Correction d'un bug qui empêchait le démarrage sur certains systèmes à base de Pentium 4.
    • Changement de licence : en plus d'être gratuit le programme est maintenant opensource (GPL).
  • 3.4.2 (02/03/2003)
    • Importation/Exportation avec le site Origons.
    • Quelques nouvelles options d'Exportation, dans la fenêtre des Préférences.
    • Quelques corrections de bugs.
  • 3.4.1 (22/12/2002)
    • La fenêtre d'image peut être accrochée (dockée) du côté droit de la fenêtre principale.
    • L'image téléchargée (dans l'extraction d'information via un script) peut être visualisée avant de cliquer OK.
    • Option pour générer des requêtes "update" plutôt que des requêtes "insert" dans l'exportation SQL.
    • Commandes de recherche de texte dans l'éditeur de script.
    • Quelques corrections de bugs et options ajoutées.
  • 3.4.0 mise à jour (04/10/2002)
    • Correction de quelques petits détails.
    • Ajout de l'importation des bases de Divx Manager 1.0.
  • 3.4.0 (08/09/2002)
    • Impression, utilisant des modèles personnalisables.
    • En mode Tableau, la taille et l'ordre des colonnes sont sauvés.
    • Downloads threadés : devrait résoudre quelques problèmes de la fenêtre principale & fenêtre de script lors du download d'une page web.
    • Importation du bitrate vidéo et audio des fichiers AVI.
    • Fonctions pour modifier la casse (majuscule, minuscule, mixte...) dans l'outil de Scripting.
  • 3.3.1 (30/07/2002)
    • Support des fichiers XML : vous pouvez choisir d'utiliser des fichiers XML pour vos catalogues plutôt que le format binaire ".amc".
    • Les options et contenu des listes déroulantes sont stockés dans un fichier XML plutôt que des fichiers INI/TXT.
    • Ajout d'options pour les listes déroulantes, par ex. la possibilité d'utiliser les valeurs du catalogue plutôt que les celles des listes prédéfinies.
    • Importation des images lors de l'importation des fichiers de Divx Manager & BaseDVDivx.
    • Un clic sur l'image dans la fenêtre principale affiche une nouvelle fenêtre contenant l'image à sa taille rélle.
    • Les valeurs par défaut des nouveaux films peuvent être modifiées depuis la fenêtre des Préférences.
    • Possibilité de lier les images lors d'un drag & drop sur la fenêtre principale.
    • Option pour spécifier le type de nom de fichier donné aux images lors de l'exportation.
    • Lors de l'exportation SQL ou CSV, une colonne contenant le nom de l'image est ajoutée si les images sont exportées.
    • Les requêtes de page web depuis le script peuvent utiliser la méthode POST au lieu de GET si nécessaire (expérimental).
    • Drapeaux dans la liste de choix de la langue.
  • 3.3.0 mise à jour (22/06/2002)
    • Correction d'un problème de tri de la liste de films dans la fenêtre de gestion des prêts.
    • Nouveaux scripts.
  • 3.3.0 mise à jour (10/06/2002)
    • Corrected a bug in the SQL Export (only visible on Unicode systems).
    • Corrected a bug in the function HTMLDecode for the Scripting.
  • 3.3.0 (26/05/2002)
    • Deux nouveaux champs : "Origine" (où/comment vous avez eu le film) et "Type de support" (CD, DVD, VHS, ...).
    • "Affichage groupé" (Menu "Outils"), permettant d'afficher la liste comme une sorte d'arborescence.
    • "Affichage en tableau", affichant toutes les informations de films dans une large liste plutôt que l'aspect habituel (pour le moment vous ne pouvez rien modifier dans ce mode).
    • Nouvelle fenêtre de recherche, qui se comporte comme une barre d'outils, permettant de la garder ouvert lors de l'utilisation de la liste de films. Aussi une option "Afficher les résultats" qui affiche seulement les films répondant aux critères de la recherche.
    • Possibilité de sélectionner plus d'un élément pour la suppresion, cases à cocher, scripting, ...
    • Sauvegarde de l'ordre dans lequel les lists sont triées (dans la fenêtre principale et la fenêtre de gestion des prêts).
    • Mise à jour vers la dernière version de TPNGImage : les images PNG supportent maintenant des transparences 32 bits.
    • Désactivation des animations des GIF, car cela était affreusement lent à charger.
    • Nouvelle fenêtre pour l'imagee : le dock/undock (ancrage) fonctionne mieux.
    • Mise à jour vers tb2k/tbskin 2.0.13.
    • Importation d'un autre fichier .amc dans le fichier actuel.
    • Importation des fichier .bdv de BaseDVDivx 2.5.
    • Importation des bases de DivxManager 0.5, 0.6 & 0.8
    • Exportation de fichiers HTML complets ou individuels : possibilité de faire un fichier par film, utile pour les longues listes.
    • Lors de l'importation de fichiers avi/divx, le programme importe aussi le nom des codecs vidéo & audio.
    • Importation des fichiers .film de www.moviecovers.com.
    • Vitesse améliorée pour le démarrage et la fermeture, et pour le rafraîchissement de la liste.
    • Mode Scripting : Exécution d'un script pour une list de films, ce qui permet une importation en masse, recherche/remplace, etc...
    • Dans la fenêtre de script, une page affiche les scripts trouvés dans le dossier "Scripts", pour une sélection facile du script.
    • Importation de l'image du film avec les scripts en plus des informations de films.
    • Éditeur avec coloration syntaxique pour l'édition du modèle HTML et du script.
    • Option pour exécuter automatiquement le script lors de l'ouverture de la fenêtre de script.
    • Option pour ouvrir un catalogue spécifique au démarrage, ou réouvrir le dernier catalogue utilisé.
    • Option pour placer les mots tels que "Le", "Un", ... à la fin du titre lors de leur affichage dans la liste (par défaut les mots anglais et français sont dans la liste).
    • Option pour désactiver l'auto-complétion des listes déroulantes, étant donné que certains avaient des problèmes avec cela.
    • Lors de l'ajout d'un film, option pour utiliser le premier numéro disponible plutôt que le plus haut numéro + 1. Aussi des options pour ouvrir automatiquement les fenêtres d'extraction d'information de script et de fichiers.
    • Quelques autres options.
    • Amélioration des icônes en 16x16, et ajout d'une icône 48x48.
  • 3.2.1 mise à jour (26/02/2002)
    • Correction d'un bug dans la fenêtre de progression (ouverture/sauvegarde/exportation/...) avec les fenêtres modales.
    • Correction d'un bug lors de l'importation CSV (dans la version du 18/02/2002).
    • Mise à jour vers la nouvelle version de Toolbar2000 et TBSkin.
  • 3.2.1 (16/02/2002)
    • Amélioration du système de script, ajout d'un script pour l'importation de données de www.allocine.fr, et correction d'un bug : crash lors de l'importation de descriptions trop longues.
    • Correction du bug des éléments non traduits sous Windows 95/98. Tout devrait être traduit correctement maintenant.
    • Amélioration de la vitesse de rafraîchissement de la liste de films (lors du chargement d'un fichier, validation des options ou renumérotation des films).
  • 3.2.0 (09/02/2002)
    • Possibilité de récupérer des informations de films sur internet ! Le programme utilise un système de script, basé sur le Pascal Object. La version initiale n'inclue qu'un script pour importer les données d'IMDB, mais d'autres scripts seront disponibles bientôt.
    • Menu personnalisable par l'utilisateur, pouvant lancer le navigateur web par défaut pour effectuer une recherche à propos d'un film sur internet.
    • Enregistrement des entrées/sorties des prêts, dans un fichier CSV.
    • Plusieurs collections d'icônes, pouvant être modifiées ou créées par l'utilisateur en ajoutant des fichiers .bmp dans le dossier de l'application.
    • Graphiques "camembert" ajoutés pour la fréquence (images/sec), les années et les durées de films.
    • Tag de passage à la ligne personnalisable pour l'exportation HTML.
    • Nouvelle fenêtre pour la renumérotation des films, permettant de spécifier le type de tri à effectuer avant la renumérotation.
    • Mise à jour vers la nouvelle version de Toolbar2000 et TBSkin.
    • Support des thèmes de Windows XP (l'application utilise le thème de Windows).
    • Correction du bug du tri avancé, ainsi que quelques autres bugs.
    • Conversion de l'aide vers le format CHM.
  • 3.1.0 mise à jour (08/01/2002)
    • Quelques petits bugs corrigés.
  • 3.1.0 (22/12/2001)
    • Champs de longueur illimitée (en fait limité à 2147483647 caractères sous Windows NT/2000/XP et 65535 sous Windows 95/98/ME).
    • Nouveaux champs : Format audio, Débit audio & vidéo, Nombre de disques, Fréquence, Label/Code-barre.
    • Statistiques : Graphique avec des statistiques sur le catalogue, par ex la fréquence des ajouts, les pays, les catégories, etc...
    • Nouvelle fenêtre de recherche, permettant de rechercher un film sur la base de n'importe quel champ.
    • Un nouveau film est ajouté si l'on "drag & drop" des fichiers lorsqu'aucun film n'est sélectionné.
    • Nouvelles actions pour l'image : "Copier vers le presse-papiers", "Lier une image" (Ce qui permet de ne sauver qu'un lien vers l'image au lieu de la stocker dans le catalogue).
    • Support du PNG pour les images de films.
    • Image incluses lors d'un copier/coller.
    • Nouvelles options : "Adapter la taille de l'image à la fenêtre", "Désactiver le logo au démarrage", "Touches de raccourci pour passer au film précédent/suivant sans perdre le champ actif".
    • Nouveaux tags pour l'exportation HTML : $$FORMATTEDTITLE 1 & 2.
    • Nouveau système de barres d'outils et menus, avec des "skins" (Office 2000, Office XP, Windows XP).
    • Nouvelle propriété du catalogue : "Description".
    • Conversion de Delphi 5 vers Delphi 6.
  • 3.0.1 (28/10/2001)
    • Traduction français complète, d'autres langues vont suivre.
    • Meilleure gestion des fichiers lors d'un "drag & drop".
    • Possibilité de sauver une copie de l'image d'un film vers un nouveau fichier.
  • 3.0.0 mise à jour (24/10/2001)
    • Correction d'un petit bug avec Windows XP et les champs numériques (champs avec des flèches pour modifier la valeur).
    • Correction d'un bug étrange qui n'arrivait que sur certains systèmes : au démarrage du programme il demandait parfois à l'utilisateur s'il désirait sauver le fichier.
  • 3.0.0 (14/10/2001)
    • Nom du programme modifié : maintenant il s'agit de Ant Movie Catalog à la place de ANSYsoft Movie Catalog, car le groupe ANSYsoft a plus ou moins disparu.
    • Les images et prêts sont stockés dans le fichier du catalogue. C'est pourquoi les fichiers sont plus gros. Donc les .jpg, .gif et .amcl ne sont plus utiles: ils sont inclus au .amc.
      Possibilité de sauver le catalogue sans les images (par exemple pour envoyer par mail un fichier un peu plus petit) en sélectionnant "Ant Movie Catalog 3.0 without images or loans" dans la fenêtre "Sauver sous" (enregistrement sous un autre nom).
    • Meilleure manipulation des dates pour le champ "Date d'ajout".
    • Autorise d'entrer une valeur vide pour l'année ou la longueur dans les informations du film.
    • Le film sélectionné devient visible dans la liste lors de la recherche ou de l'ajout.
    • Le numéro de film peut être modifié (via le menu contextuel dans la liste ou par le menu "Film").
    • Fenêtre de progression lors du chargement/sauvegarde.
    • Suppression de la fenêtre "Importer infos" car elle ne paraissait pas vraiment utile. Maintenant il est possible de faie un drag & drop d?un fichier vidéo sur la fenêtre du programme pour importer la taille des fichiers. S'il s'agit d'un AVI ou Divx la résolution d'image et la durée peuvent également être importés.
    • Fenêtre des options un peu modifiée et ajout de nouvelles options.
    • Meilleure gestion des modèles dans l'export HTML.
    • Option pour spécifier si les images doivent être également exportées déplacée de la fenêtre des options vers la fenêtre d'export.
    • Fonction d'export des images uniquement ("Images only").
    • Fenêtre des propriétés modifée.
    • Logo affiché au démarrage.
    • Beaucoup de petits changements.
  • 2.1.1 mise à jour (14/08/2001)
    • Correction d'un bug dans la fenêtre "Save as" et dans les autres fenêtres similaires.
  • 2.1.1 (22/07/2001)
    • Traduction française partielle.
    • Correction d'un bug dans l'exportation SQL.
  • 2.1.0 (12/07/2001)
    • Beaucoup de petits bugs corrigés.
    • Le nombre de films du catalogue est visible dans la barre de titre.
    • Les derniers fichiers utilisés apparaissent dans le menu "Fichier".
    • Menu contextuel pour la liste de films dans la fenêtre principale.
    • Fonction "Renuméroration".
    • La fenêtre de l'image du film peut être "dockée" (intégrée) dans la fenêtre principale, sous la liste de films.
    • Support du "Drag & Drop" dans la fenêtre principale : les fichiers peuvent être ouverts de cette manière à présent.
    • Option pour afficher des cases à cocher dans la liste de films pour specifier si un film doit être inclus ou non dans l'exportation.
    • Nouveau champ : "Date d'ajout", donc un nouveau format de fichier (le programme peut toujours ouvrir les anciens fichiers, mais les versions précédentes du programme ne pourront pas ouvrir les fichiers sauvés avec cette version-ci).
    • Fenêtre "Propriétés du fichier" affichant les informations sur le propriétaire du catalogue.
    • Même style de barre d'outils pour toutes les fenêtres (grisée ou toujours colorée, selon le choix fait par l'utilisateur dans la fenêtre des options).
    • Recherche d'un film sur la base de son titre, dans la fenêtre principale et dans la fenêtre des prêts.
    • Dans la fenêtre des prêts, le nombre de films que chaque personne a empruntés est toujours visible.
    • Options de tri avancées dans la fenêtre d'exportation.
    • Exportation vers SQL.
    • Quelques nouveaux tags pour l'exportation HTML, par exemple $$ITEM_PICTURENAME qui donne juste le nom de fichier de l'image ($$ITEM_PICTURE créait un tag <img>).
  • 2.0.0 (30/05/2001)
    • Importation et exportation de fichiers CSV (fichiers textes où les champs sont délimités par un caractère spécial, utilisable dans la plupart des bases de données et programmes du genre d'Excel).
    • Quelques bugs corrigés pour la détection de la modification du fichier en cours.
    • L'importation des informations d'un film peut maintenant créer une chaîne contenant les tailles de tous les fichiers sélectionnés (par exemple. 600+350+100 à la place de 1050).
    • Quelques problèmes de personnalisation de la barre d'outils résolus (pas tous).
    • Correction d'un bug dans le tri par titre de film de l'exportation HTML et dans la liste de films de la fenêtre principale (lors d'un clic sur le titre d'une colonne).
    • Fenêtre "Prêts" permettant de gérer les films que vous amis vous empruntent.
  • 1.1.0 (15/04/2001)
    • Nouveau champ : Image et Appréciation.
    • Nouveau format de fichier (requis pour les nouveaux champs). Les fichiers de la version 1.0 sont toujours utilisables (bien sûr !) mais les nouvaux fichiers ne seront pas utilisables par l'ancienne version du programme.
    • Amélioration de la fenêtre d'exportation.
    • L'importation d'informations de films permet maintenant de récupérer la résolition des vidéos AVI.
    • La largeur de la liste dans la fenêtre principale est maintenant sauvegardée (ainsi que la taille de la fenêtre).
    • Fenêtre des options refaite.
    • Personnalisation de la barre d'outils.
    • Copier/Coller des informations de film (par exemple pour échanger des informations entre deux instances de l'application tournant en même temps).
    • Correction d'un bug dans la fonction "Annluer".
    • Pages d'aide.
  • 1.0.0 (18/03/2001)
    • Première version. Certaines fonctionnalités ne sont pas encore terminées. Cela viendra dans les versions suivantes.


Informations sur l'auteur, crédits et liens

Ce programme a été créé par Antoine Potten avec Borland Delphi 7 sous Windows XP.

Il est prévu pour tourner sur les versions 32 bits de Windows et a été testé sous Windows 95, 98, NT4, 2000 et XP. Il fonctionne également sans problème sous Windows ME et 2003.

Il vous faudra peut-être installer une mise à jour pour votre système si vous utilisez Windows 95, 98 ou NT4. Consultez la page des téléchargements de mon site pour des liens vers les pages de téléchargement du site de Microsoft.

Au départ j'avais fait ce programme parce que je n'avais aucun programme capable de gérer ma liste de film et créer facilement une page HTML avec cette liste.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR APARTICULAR PURPOSE. See the GNU General Public License for more details.

Contact

  • Mail : software@antp.be
  • Page du programme Ant Movie Catalog : www.antp.be/software/moviecatalog/fr/

Liens

Merci aux sites suivant qui fournissant un accès direct à leurs données aux utilisateurs d'Ant Movie Catalog :

  • DVDFR
  • Culturalia

Icônes utilisées pour les différents thèmes :

  • Scrows' glyphs collections
  • Gnome
  • Everaldo's Crystal icons

Composants utilisés :

  • InnoSetup, utilisé pour la procédure d'installation
  • MediaInfo, utilisé sous forme de DLL
  • Quelques composants de la JVCL
  • Innerfuse Pascal Script version 2
  • TPNGImage
  • CorelButton
  • Toolbar2000
  • TBX
  • SynEdit
  • ElTree Lite
  • FreeReport
  • MyLittleBase, utilisé pour la DLL gérant l'importation de BaseDVDivx

Traductions :

  • Allemand : Johannes Ebner, Bad Joker & Juergen Venne
  • Biélorusse : dzmitry[li]
  • Bulgare : Rumen Stoyanov & Momchil Karabulev
  • Catalan : Pau Bosch i Crespo
  • Coréen : 장주을 (Ju Eul, Jang)
  • Croate : Josip Martinčević
  • Danois : Bent Møller Madsen
  • Espagnol : Sergio Marrero Ponce
  • Estonien : Junos
  • Finnois : Jukka-Pekka Jussila
  • Français : Antoine Potten
  • Grec : AllDivXGR
  • Hébreu : Erez Ben Ari
  • Hongrois : Herczeg József Tamás
  • Italien : Jancker & Dino Librandi
  • Letton : Aldis Bîbers
  • Lituanien : Vytautas Ribikauskas
  • Macédonien : Wekoslav Stefanovski
  • Néerlandais : Harm Caspers & Marcel Buyle
  • Norvégien : rulle & Kai V Findahl
  • Polonais : Adam "Adma's" Malich & Bogdan Kwietniak
  • Portugais (Brésil) : Filipe Guimarães
  • Portugais (Portugal) : Ricardo Ribeiro
  • Roumain : Dragoş Medinschi
  • Russe : m a x, Alexei Chehowskoi & Vitaliy Krivchikov
  • Serbe : Zoran "ZoNi" Nikolic & Ivan
  • Slovaque : Berry
  • Slovène : Pete Minus
  • Suédois : Andreas Johansson
  • Tchèque : Jan Kaltoun & Kříz
  • Turc : Özkan Ak & Kemal Seçer